Remote report processing requires Microsoft SQL Server 2008 Reporting Services or later.


Recently I modified one of my SSRS projects to use ReportViewerControl 2010 version instead of the old version by downloading the control from here http://www.microsoft.com/downloads/details.aspx?FamilyID=a941c6b2-64dd-4d03-9ca7-4017a0d164fd&displaylang=en.

After compiling my project and publishing it I tried to run the report and ran into the error

Remote report processing requires Microsoft SQL Server 2008 Reporting Services or later.

After a bit of surfing I realized that the prerequisites in the microsoft download page of the control listed this

  • Microsoft SQL Server 2008 Reporting Services or higher for server processing mode
  • .NET Framework 3.5 SP1 or .NET Framework 4.0

Hmm. Strange. So be careful before you migrate your report viewer control for your SSRS projects from version 2008 to 2010. Make sure you have SQL Server 2008 at the server.

NLV

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s